Anyone have built gitea + drone successfully?

I`m having issues of gitea not triggering build on drone. Using version 0.8, here is docker-compose:

version: ‘3’
services:
nginx:
image: nginx
volumes:
- ./data/nginx/site:/etc/nginx/conf.d/site
ports:
- 80:80
environment:
- NGINX_PORT=80
networks:
- frontend
- backend

  mysql:
    image: mysql
    command: --default-authentication-plugin=mysql_native_password
    restart: always
    volumes:
      - ./data/mysql:/var/lib/mysql
    environment:
      MYSQL_ROOT_PASSWORD: root
      MYSQL_DATABASE: gitea
      MYSQL_USER: gitea
      MYSQL_PASSWORD: gitea
    networks:
      - backend

  gitea:
    image: gitea/gitea:1.3.2
    volumes:
      - ./data/gitea:/data
    ports:
      - "3000:3000"
    depends_on:
      - mysql
    restart: always
    networks:
      - frontend
      - backend
    environment:
      - USER_UID=1000
      - USER_GID=1000
      - DB_TYPE=mysql
      - DB_HOST=mysql:3306
      - DB_NAME=gitea
      - DB_USER=gitea
      - DB_PASSWD=gitea

  drone:
    image: drone/drone:0.8
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
      - ./data/drone:/var/lib/drone
    environment:
      - DRONE_OPEN=true
      - DRONE_GITEA=true
      - DRONE_GITEA_URL=http://gitea:3000
      - DRONE_GIT_ALWAYS_AUTH=false
      - DRONE_RUNNER_CAPACITY=2
      - DRONE_HOST=http://localhost
      - DRONE_SERVER_PROTO=http
      - DRONE_TLS_AUTOCERT=false
      - DRONE_SECRET=test
      - DRONE_DATABASE_DRIVER=mysql
      - DRONE_DATABASE_DATASOURCE=drone:[email protected](mysql:3306)/drone?parseTime=true
    restart: always
    ports:
      - 8081:8000
      - 9000
    networks:
      - frontend
      - backend
    depends_on:
      - gitea
      - mysql

  drone-agent:
    image: drone/agent:0.8
    command: agent
    depends_on:
      - drone
    restart: always
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
    environment:
      - DRONE_SERVER=drone:9000
      - DRONE_SECRET=test
    networks:
      - frontend
      - backend


networks:
  frontend:
    driver: bridge
  backend:
    driver: bridge

Looks like you’re using environment variables from drone 1.0.0-rc1, but using the drone 0.8. If you want to use 0.8 check out this documentation for Gitea integration. Otherwise, try using 1.0.0-rc1 instead.