Build shows running when all steps complete

I’ve seen this before. The build shows as running, but all steps are complete.

06%20PM

See https://github.com/drone/drone/issues/2090

TLDR

  1. make sure you are not running an older version of drone. 0.8.4 is the latest stable
  2. make sure you are not running an old version of Docker, which has a known issue where streaming logs will lock, and block indefinitely. Docker 17.04 or higher is recommended.

Hi Brad, thanks for your reply. I have two agent machines, one is running a slightly older version of docker but else they’re the same.

[email protected]:~$ sudo docker exec -t drone_agent /bin/drone-agent -v
drone-agent version 0.8.4+build.1388
[email protected]:~$ docker -v
Docker version 17.05.0-ce, build 89658be
[email protected]:~$
[email protected]:~$ uname -a
Linux lab1.ops.tropo.com 4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux


[email protected]:~$ docker -v
Docker version 17.12.0-ce, build c97c6d6
[email protected]:~$ sudo docker exec -t drone_agent /bin/drone-agent -v
drone-agent version 0.8.4+build.1388
[email protected]:~$ docker -v
Docker version 17.12.0-ce, build c97c6d6
[email protected]:~$ uname -a
Linux lab2.ops.tropo.com 4.4.0-112-generic #135-Ubuntu SMP Fri Jan 19 11:48:36 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

And on my drone master:

-->[[email protected] ~]$ sudo docker exec -t drone /bin/drone-server -v
drone-server version 0.8.4+build.1388

What do you see in your agent logs? server logs? In general, when a build is not being updated, I would assume the agent has lost connectivity to the server and is having difficulty re-connecting.

EDIT I should mention that when you add DRONE_DEBUG=true to the agent it will produce very detailed logs, allowing us to see exactly thing are locking up.

Ok, I’ll do that. Is there a place I can send them to you under the radar? Happy to share resolution here, but I probably can’t have raw logs in public.

Another admin upgraded lab1 to 17.12 so maybe the issue just goes away.

Sure, you can always send me a private message in discourse with the logs