Drone-cli tool - new changes in latest

Hello to all !

We have made some significant changes to the drone-cli tool. This is a vision to modernise some parts of the tool and improving the functionality.
In the tool we have modified 3 sub commands to follow the more modern Drone 1.X/2.X compilers. We have also added an alternative to the exec command. How you use the commands should have stayed the same.

lint subcommand - use the docker compiler from drone-runner-docker, means it will handle more modern features from the docker runner and there are checks for interdependencies between stages.

convert subcommand - this was used to convert from 0.8 build files to 1.X/2.X and has been deprecated.

sign subcommand - no change in functionality, just moving code from the deprecated drone-yaml

exec2 subcommand - the biggest change, using the exec code from drone-runner-docker, giving all of the functionality of drone-runner-docker. This is an alternative implementation of the exec command. exec still exists but with a vision of being deprecated.

Please feel free to let us know in discourse if you have any feedback. If you have an issue, providing a build example would help us replicate the issue and get a fix in.

1 Like