I don't see trusted option after setting up admin user

Hi, after i setting up admin user, i still see Trusted option in Project settings .

file: drone.sh

docker run -d --name=drone \
  ...........
  --volume=$(pwd)/drone:/data \
  --env=DRONE_USER_CREATE=username:[email protected],admin:true \
  --env=DRONE_GITLAB_SERVER=https://gitlab.com \
  --env=DRONE_GITLAB_CLIENT_ID=${GITLAB_CLIENT_ID} \
  --env=DRONE_GITLAB_CLIENT_SECRET=${GITLAB_CLIENT_SECRET} \
  --publish=8086:80 \
  --restart=always \
  drone/drone:1

run docker logs drone shows:

{"level":"info","msg":"main: internal scheduler enabled","time":"2020-04-30T00:23:04Z"}
{"admin":true,"level":"info","login":"[email protected]","machine":false,"msg":"bootstrap: account created","time":"2020-04-30T00:23:04Z","token":"Ga3ZlXhWpQG8waXu7iGeGGehSZirlAEM"}

but it’s ok on anothor server.

you need to provide drone with your username, not your email address.

1 Like

you are right, verfy thanks.