Not able to install Delegate on GKE

Getting below error -

Readiness probe failed: Unhealthy Aug 19, 2021, 1:14:57 PM Aug 19, 2021, 1:34:37 PM 111
Pulling image harness/delegate:latest Pulling Aug 19, 2021, 1:14:32 PM Aug 19, 2021, 1:14:32 PM 1
Successfully pulled image harness/delegate:latest in 162.963829ms Pulled Aug 19, 2021, 1:14:32 PM Aug 19, 2021, 1:14:32 PM 1

Error

2021-08-19 13:38:33.059 IST

#=#=# ##O#- # ##O=# # #=#=-# # -#O#- # # -=#=# # # -=O#- # # # -=O=# # # # -=O=-# # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # # -=O=- # # # #

Info

2021-08-19 13:38:33.376 IST

Watcher not running

Info

2021-08-19 13:38:33.378 IST

Delegate not running

I have configured proxy and also test the connection using the command “wget -p https://app.harness.io/ -O /dev/null” . the response was successful.

Welcome to the Community! Hmm the does that occur over more than one polling intrival? E.g keeps appearing in the logs?

I don’t see a connection error there nor any info if the health check failed, etc. Does that show up?

Though if you are thinking it is a connectivity issue, were you attempting that wget command from inside the running container?

 kubectl exec <pod-name> -n harness-delegate -it -- bash

Lastly not sure if you are pruning the delegate e.g reducing the Resource Limits to something
really small to fit on a GKE node.

Relevant docs:
Proxy settings in K8s:

Hi Ravi, Thanks for the reply. I was able to configure the delegate after setting the value for “POLL_FOR_TASKS” to “true” in yaml.

However, now I am stuck at the container creation step. getting error-

Failed to pull image "gcr.io/gcp-keng01/hca-backend-tomcat-develop-k8s:178": rpc error: code = NotFound desc = failed to pull and unpack image "gcr.io/gcp-keng01/hca-backend-tomcat-develop-k8s:178": failed to unpack image on snapshotter overlayfs: failed to extract layer sha256:eada838fb7777f76b5776c6b4f1cd7694f86a49c39001c931ef04ca324472614: failed to get reader from content store: content digest sha256:9a960853d26c8ea4055375ba6debc7e6436c4ad0c69d97c890209bfb2b6cc212: not found Failed

Hmm scratching my head on this one. Will hitup some folks internally.

@Himanshu_Jaggi can you provide some more information about your GKE Instance?

  1. Machine type e.g which Linux Distro of the worker nodes
  2. Which version of Kubernetes you are running in GKE
  3. Node size e.g how much memory. If you have Kube Metrics, is there sufficient capacity
    on the node e.g kubectl top nodes to see if the memory pressure is not there for some process throttle/killer to run?

-Ravi

Hmm, "gcr.io/gcp-keng01/hca-backend-tomcat-develop-k8s:178" is not our image. Is that a deployment you are trying to deploy?