Upgrade to drone 0.8 errors

Drone upgrades fine, i can access to the admin panel, but got none repositorys. and when i click “Synchronize” button, i got this response in chrome panel

Error fetching repository list. sql: Scan error on column index 12: sql/driver: couldn't convert <nil> (<nil>) into type bool

here is my docker-compose file

version: '2'

services:
  drone-server:
    image: drone/drone:0.8
    ports:
      - 10081:8000
      - 10090:9000
    volumes:
      - ./drone:/var/lib/drone/
      - /tmp/cache:/cache
    restart: always
    environment:
      - DRONE_OPEN=true
      - DRONE_DEBUG=false
      - DRONE_DATABASE_DRIVER=mysql
      - DRONE_DATABASE_DATASOURCE=root:[email protected](docker.for.mac.localhost:3306)/drone?parseTime=true
      - DRONE_GOGS=true
      - DRONE_GOGS_URL=http://docker.for.mac.localhost:10080
      - DRONE_GOGS_PRIVATE_MODE=true
      - DRONE_GOGS_SKIP_VERIFY=true
      - DRONE_SECRET=123213123123
      - DRONE_ADMIN=memosa
      - DRONE_HOST=http://docker.for.mac.localhost

  drone-agent:
    image: drone/agent:0.8
    restart: always
    depends_on: [ drone-server ]
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
      - /tmp/cache:/cache
    environment:
      - DRONE_SERVER=drone-server:9000
      - DRONE_SECRET=123213123123
      - DRONE_HOST=docker.for.mac.localhost

i opened debug mode, and got these debug log

I delete my Drone 0.7 database, and restart it. and everything works ok now.:grin:

1 Like