White page when launching a build

Hello,

I just discovered Drone, I have a Gitea running in Docker in a Raspberry Pi (with a working Traefik).
I have added Drone to the Docker, succesfull logged in Gitea, can see my repositories and can lauch a build.
But when a launch a build and i go to build page i got a white page with this error :

Here is the relevant Docker config :
drone-server:
image: drone/drone
container_name: drone-server
restart: unless-stopped
ports:
- 8111:80
environment:
- TZ=${TZ}
- DRONE_RPC_SECRET=${DRONE_RPC_SECRET}
- DRONE_GITEA_SERVER=https://git.mydomain.com
- DRONE_GITEA_CLIENT_ID=${DRONE_GITEA_CLIENT_ID}
- DRONE_GITEA_CLIENT_SECRET=${DRONE_GITEA_CLIENT_SECRET}
- DRONE_SERVER_HOST=drone.mydomain.com
- DRONE_SERVER_PROTO=https
- DRONE_USER_CREATE=username:myuser,admin:true
volumes:
- ./drone:/data
depends_on:
- gitea
labels:
traefik.enable: true
traefik.docker.network: proxy
traefik.http.routers.drone-server.entrypoints: websecure
traefik.http.routers.drone-server.rule: Host(drone.mydomain.com)
traefik.http.routers.drone-server.middlewares: [email protected]
# TLS
traefik.http.routers.drone-server.tls.certresolver: ovh
traefik.http.routers.drone-server.tls.options: [email protected]
networks:
- proxy
- internal

Example .drone.yml:


kind: pipeline
type: docker
name: default

steps:

  • name: frontend
    image: node
    commands:
    • npm install
    • npm run test:unit

I tried a bunch of things like running another Drone on a UnRAID server with a x64 architecture with a Gitlab server but everytime i got the same error.

I believe this is a duplicate of [FIXED] Drone 2.0 - UI shows white page and "TypeError: i is undefined" - #12 by urbanswelt. The solution was to upgrade to a newer version of Drone server where the issue has been resolved.

How i can see the version of my drone server ?
I’m using the latest image from DockerHub, it’s not supposed to be fixed in that version ?

EDIT : same issue with differents images drone/drone:latest, drone/drone:linux-arm or drone/drone:2.0.1